Power Outage
Incident Report for Brother Rice High School
Resolved
All residual issues have been resolved.

Power was restored 4/16 at 3:46pm for an outage length of just under 24 hours.
Posted 3 months ago. Apr 18, 2018 - 14:05 EDT
Monitoring
Power at the school has been restored. Most services will be online within the hour. Any residual issues will be listed at help.brrice.edu
Posted 3 months ago. Apr 16, 2018 - 15:49 EDT
Update
Power continues to be out. Students can access Schoology via iPads or http://schoology.brrice.edu. Pearson eBook issues from last night have been resolved.
Posted 3 months ago. Apr 16, 2018 - 05:22 EDT
Identified
Power is out at 7101 Lahser Rd as of 5:30pm. Most service will be unavailable until after power is restored.
Posted 3 months ago. Apr 15, 2018 - 17:45 EDT