Schoology unavailable at times
Incident Report for Brother Rice High School
Resolved
This incident has been resolved.
Posted almost 2 years ago. Oct 31, 2016 - 14:38 EDT
Monitoring
Schoology has fixed the issue and we are monitoring until the end of the day.
Posted almost 2 years ago. Oct 31, 2016 - 14:05 EDT
Investigating
We have received several reports that Schoology is unavailable via Web or Mobile.
Posted almost 2 years ago. Oct 31, 2016 - 13:53 EDT