Primary Internet connection unavailable
Incident Report for Brother Rice High School
Resolved
The connection has been repaired and everything should be functioning at normal speeds for the start of the school-day.
Posted 6 months ago. Jan 25, 2018 - 21:48 EST
Identified
Our provider has identified a cut in their fiber rin in Southfield. Repair is being scheduled now.
Posted 6 months ago. Jan 25, 2018 - 14:00 EST
Investigating
Our primary Internet connection is down. All users will still be able to access the Internet but speeds will be reduced.
Posted 6 months ago. Jan 25, 2018 - 12:14 EST