iPad printing unavailable
Incident Report for Brother Rice High School
Resolved
Printing is now available.
Posted over 1 year ago. Dec 14, 2016 - 13:57 EST
Investigating
Printing from Student or Staff iPads is currently unavailable. We are investigating the cause and will notify when resolved.
Posted over 1 year ago. Dec 14, 2016 - 13:07 EST