Input power issues
Incident Report for Brother Rice High School
Resolved
2nd largest storm in DTE history and Brother Rice survived! Everything back online.
Posted over 1 year ago. Mar 08, 2017 - 22:57 EST
Identified
We have experienced approximately 5 minutes of low/no input voltage to the school and have preemptively shut down some internal services.
Posted over 1 year ago. Mar 08, 2017 - 16:22 EST