Power Outage
Incident Report for Brother Rice High School
Resolved
Remaining issues have been resolved.

The power outage lasted 12 hours and 47 minutes.
Posted 6 months ago. May 06, 2018 - 15:14 EDT
Monitoring
Power was restored just before 4:00am. With the exception of a few classroom issues, all services are working normally.
Posted 7 months ago. May 06, 2018 - 06:33 EDT
Identified
Power is out at 7101 Lahser Rd as of 2:50pm. Most services will be unavailable until after power is restored.
Posted 7 months ago. May 05, 2018 - 15:54 EDT