PowerSchool outage
Incident Report for Brother Rice High School
Resolved
The Anycast/CDN provider reports that connectivity in the Toronto Region has returned to normal.
Posted 7 months ago. May 30, 2018 - 16:56 EDT
Update
PowerSchool has determined that there is an ongoing issue with their Anycast provider, Incapsula, in the Toronto area. https://status.incapsula.com/incidents/drtmhfj6w5bz

We have forced internal traffic to another ISP to avoid the issue until it is resolved.
Posted 7 months ago. May 30, 2018 - 12:24 EDT
Monitoring
Our PowerSchool instance has been reachable the rest of the academic day. We will remain in a monitoring state for one additional school day.
Posted 7 months ago. May 29, 2018 - 17:43 EDT
Identified
PowerSchool was restored at 1:29pm for an outage of 57 minutes.
Posted 7 months ago. May 29, 2018 - 14:08 EDT
Investigating
We are currently in contact with PowerSchool regarding their hosting services. PowerSchool has been unavailable for various 2-5 minute periods since Friday (5/25) but has not been unavailable since 12:32pm.
Posted 7 months ago. May 29, 2018 - 12:49 EDT
This incident affected: Core Education Services (PowerSchool).