Power outage
Incident Report for Brother Rice High School
Resolved
The electrical issue has been resolved.
Posted almost 2 years ago. Dec 27, 2016 - 16:21 EST
Investigating
The power to parts of Old Monastery Hall has been disconnected. Several services are currently unavailable.
Posted almost 2 years ago. Dec 27, 2016 - 13:43 EST