BRHS Website DOWN
Incident Report for Brother Rice High School
Resolved
The website outage has been resolved. All visitors should now see the homepage rendered correctly. If you are still experiencing issues, contact techhelp@brrice.edu.
Posted Nov 05, 2018 - 15:44 EST
Identified
We have identified the problem and are working to implement a fix. The ETA is approximately 5 minutes.
Posted Nov 05, 2018 - 15:34 EST
Investigating
The BRHS website was reported as DOWN at 4:30:51. We are currently investigating the issue.
Posted Nov 05, 2018 - 15:06 EST
This incident affected: Business Services (Website Hosting).