Due to an Amazon Web Services outage that began earlier this morning, Schoology and several other websites are operating with degraded performance or may not be reachable at all.
Posted Oct 20, 2025 - 09:04 EDT
Identified
Due to an AWS outage early this morning, Schoology performance is degraded. Some users seeing "Temporarily Unavailable" message. Workaround: try again in a few minutes.
Posted Oct 20, 2025 - 08:18 EDT
This incident affected: Core Education Services (Schoology).