Partial Internet outage
Incident Report for Brother Rice High School
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 22:52 EDT
Investigating
Our primary Internet provider is experiencing an outage. All BRHS services remain operational.
Posted Apr 06, 2023 - 18:50 EDT
This incident affected: Internal Services (Internet Services).