Phone outage
Incident Report for Brother Rice High School
Resolved
We have been working with the vendor to address this issue.
Posted 9 months ago. Feb 26, 2018 - 22:55 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 9 months ago. Feb 21, 2018 - 11:39 EST
Identified
All users are currently experiencing sporadic phone availability for internal and external calling. We have identified the issue and are working to correct it.
Posted 9 months ago. Feb 21, 2018 - 10:47 EST