Pearson Realize unavailable
Incident Report for Brother Rice High School
Resolved
Pearson has confirmed that their services are working again. Any students still having issues should first try quitting the app or closing their browser before coming to the Tech Office for support.
Posted Apr 12, 2019 - 11:13 EDT
Monitoring
Several users have reported that they are now able to access Realize. We have no official word from Pearson yet.
Posted Apr 12, 2019 - 11:05 EDT
Update
Notified all Faculty of the problem.
Posted Apr 12, 2019 - 10:41 EDT
Identified
Pearson's K12 platform (Realize) is currently unavailable. This would impact anyone using SS or Language eBooks (not AP-levels). We have communicated with their support team and they are working on the issue but do not have an ETA on the fix.

Students using the Realize Reader app or the web interfaces (etext2.pearson.com or pearson.brrice.edu) are receiving an invalid username or password error - even when typing the correct credentials.
Posted Apr 12, 2019 - 10:25 EDT
This incident affected: eBook Providers (Savvas Realize).