Turnitin platform issues
Incident Report for Brother Rice High School
Resolved
This incident has been resolved.
Posted Nov 02, 2023 - 15:11 EDT
Monitoring
The issue accessing Turnitin has been resolved per TII. The duration of the issue was between 7:42am - 10:16am.
Posted Nov 02, 2023 - 10:56 EDT
Investigating
Turnitin is currently investigating issues with their platform including trouble logging in via Schoology and trouble submitting files. https://turnitin.statuspage.io/incidents/8d27sjrh0l12
Posted Nov 02, 2023 - 08:27 EDT