UKG Ready performance
Incident Report for Brother Rice High School
Resolved
This incident has been resolved.
Posted Feb 27, 2023 - 11:42 EST
Investigating
UKG has reached out to say that some users are experiencing slowness and inability to log in. We have not observed this at BRHS but we wanted to let you know in case it becomes an issue.
Posted Feb 27, 2023 - 09:42 EST
This incident affected: Business Services (UKG Ready).