PowerSchool intermitent availability

Incident Report for Brother Rice High School

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 21:11 EDT

Update

The reboot seems to have resolved connectivity and attendance issues. We will continue to monitor this incident through the close of business this afternoon.
Posted Mar 20, 2026 - 13:15 EDT

Identified

PowerSchool is rebooting to hopefully solve the attendance issue.
Posted Mar 20, 2026 - 12:50 EDT

Monitoring

PowerSchool acknowledged a hosting issue. They report most school servers are recovered and operating although we are still seeing some odd behavior with attendance. Stay tuned.
Posted Mar 20, 2026 - 12:32 EDT

Investigating

We have received reports that PowerSchool has been slow to respond or save attendance since at least 11:20am. We are looking into the issue and will update when we know more.
Posted Mar 20, 2026 - 11:42 EDT
This incident affected: Core Education Services (PowerSchool SIS).