3/3 Power outage
Incident Report for Brother Rice High School
Resolved
This incident has been resolved.
Posted Mar 06, 2023 - 17:15 EST
Monitoring
Power was restored at Brother Rice at 3:30pm (3/5) and all building services are now operational. If you notice any issues please report them to Technology or Maintenance at https://help.brrice.edu.
Posted Mar 05, 2023 - 21:13 EST
Identified
After 42 hours, the power is back on at 3:30pm. The building is starting to warm back up. Staff building access has been restored. Most Technology-services are operational. We will post at least one more time before tomorrow morning to confirm all is well.
Posted Mar 05, 2023 - 16:30 EST
Update
The power remains out at Brother Rice. Our restoration has been updated to Sunday (3/5). Staff should not come to the school as building access is unavailable.
Posted Mar 05, 2023 - 06:15 EST
Update
The power remains out at Brother Rice. Our restoration time is still sometime today (3/4). The parking lot and walkways are all cleared, however, staff should not come to the school as building access is unavailable.
Posted Mar 04, 2023 - 15:35 EST
Update
The power remains out at Brother Rice. As of this morning, we have been given a restoration time of sometime today (3/4). Staff should not come to the school as building access is unavailable.
Posted Mar 04, 2023 - 07:15 EST
Investigating
As of 9:02pm, Brother Rice is without utility power. We will post updates as they become available.
Posted Mar 03, 2023 - 21:25 EST
This incident affected: Internal Services (Horizon, Internet Services, Printing, Telephony).