Intermittent PowerSchool availability
Incident Report for Brother Rice High School
Resolved
This incident has been resolved.
Posted Jan 13, 2023 - 09:21 EST
Monitoring
PowerSchool has resolved the issue and we have observed a return to normal load times. We will continue to closely monitor this service through the end of the school day.
Posted Jan 12, 2023 - 10:25 EST
Identified
PowerSchool has contacted us to confirm that there is a widespread hosting issue. We are noticing slow page load times and certain operations, like taking attendance, are running slowly or not functioning correctly. We will post updates as they are made available.
Posted Jan 12, 2023 - 08:46 EST
Investigating
Since 6:00am, PowerSchool has had intermittent service issues resulting in 3-5 minute periods of inaccessibility. All PowerSchool customers in our region have been experiencing similar issues and we are waiting to hear from PowerSchool about this issue. We will post updates as they are available.
Posted Jan 12, 2023 - 07:45 EST
This incident affected: Core Education Services (PowerSchool SIS).