2/22 Power outage
Incident Report for Brother Rice High School
Resolved
This incident has been resolved.
Posted Feb 28, 2023 - 08:12 EST
Update
Recap: Brother Rice was without utility power beginning 2/22 at 8:40pm until 2/25 at 3:15am (54 hours). This includes a roughly four-hour period on 2/24 where power was briefly restored. We have confirmed that all systems are operational for Monday morning. Please report anything that isn't working correctly to TECH HELP.
Posted Feb 25, 2023 - 16:00 EST
Monitoring
All building services have been returned to normal. If you notice anything that is not working, please report it to techhelp@brrice.edu.
Posted Feb 25, 2023 - 11:48 EST
Update
Power has been restored to the school again as of 3:15am. We anticipate all technology services to be restored before Noon as long as the power stays on this time.
Posted Feb 25, 2023 - 03:45 EST
Update
Power was restored about 4:40pm but has gone out again at 8:40pm. Hopefully this is a short term issue. We will update as soon as we have more information.
Posted Feb 24, 2023 - 20:45 EST
Update
While we have seen line crews working in the area around the school, we remain without power. We will continue to post updates as information becomes available.

If you need any assistance accessing files or services from home, email techhelp@brrice.edu or call 248-905-1610.

The traffic light at Lahser/Lincoln is still out.
Posted Feb 24, 2023 - 12:00 EST
Update
The school is still without power this evening. DTE contacted us to let us know that power will not be restored on Thursday (2/23) but they committed to contacting us again on Friday (2/24) with an update.

If you need any assistance accessing files or services from home, email techhelp@brrice.edu or call 248-905-1610.

The traffic light at Lahser/Lincoln is still out.
Posted Feb 23, 2023 - 18:00 EST
Update
The school is still without power this morning and there is not yet an estimate from DTE. If you need any assistance accessing files or services from home, email techhelp@brrice.edu or call 248-905-1610.

Please do not come to the school - keycards will not work and all sidewalks/parking lot is very icy. Also, the traffic light at Lahser/Lincoln is out.
Posted Feb 23, 2023 - 10:00 EST
Investigating
Brother Rice lost utility power around 8:40pm. All service at the school building are unavailable but all primary educational services remain operations. No staff should report to the school building in the morning without checking https://help.brrice.edu for an update.
Posted Feb 22, 2023 - 21:53 EST
This incident affected: Internal Services (Horizon, Internet Services, Printing, Telephony).