9/3 Power outage

Incident Report for Brother Rice High School

Resolved

This incident has been resolved.
Posted Sep 08, 2026 - 11:20 EDT

Update

Power has been restored to the school. All services have been restored and it is safe for staff to enter the building. Please report building or technology issues.
Posted Sep 06, 2026 - 10:05 EDT

Update

Power continues to be out at the school.
Posted Sep 05, 2026 - 20:24 EDT

Update

Power continues to be out at the school.
Posted Sep 05, 2026 - 08:15 EDT

Update

Power continues to be out at the school.
Posted Sep 04, 2026 - 19:24 EDT

Update

Power continues to be out at the school.
Posted Sep 04, 2026 - 06:32 EDT

Investigating

The power is back out as of 4:05pm. The building is closed until further notice.
Posted Sep 03, 2026 - 16:39 EDT

Monitoring

Power was restored at 12:00pm. All services are operational. Please report issues at help.brrice.edu.
Posted Sep 03, 2026 - 12:25 EDT

Investigating

Power is out to the school as of 2:30am.
Posted Sep 03, 2026 - 03:17 EDT
This incident affected: Internal Services (Horizon, Internet Services, Printing, Telephony).