Power outage
Incident Report for Brother Rice High School
Resolved
This incident has been marked resolved.
Posted Aug 28, 2023 - 19:00 EDT
Update
All services are running normally today (8/28). Report any issues at https://help.brrice.edu.
Posted Aug 28, 2023 - 09:48 EDT
Update
Most services have recovered and it is now safe for staff to occupy the building. Please report any Facility replaced issues using the https://help.brrice.edu page.
Posted Aug 25, 2023 - 16:13 EDT
Monitoring
Power has been restored to the building (2:55pm). We are doing a quick inventory of services and will post another update shortly.
Posted Aug 25, 2023 - 15:00 EDT
Update
The power remains out and classes are cancelled. At this time staff and students should avoid coming to the school building - for safety reasons building access is disabled.
Posted Aug 25, 2023 - 05:25 EDT
Investigating
Power has been off at the school since 10:07pm. All building services are currently unavailable. We will post updates as they become avaialble.
Posted Aug 24, 2023 - 22:31 EDT
This incident affected: Internal Services (Horizon, Internet Services, Printing, Telephony).