7/4 Power outage

Incident Report for Brother Rice High School

Monitoring

Power has been restored as of 3:45pm.
Posted Jul 04, 2026 - 16:00 EDT

Investigating

The power at school is out as of 9:30am. No update on restoration yet. Updates will be posted as information is available.
Posted Jul 04, 2026 - 12:03 EDT
This incident affects: Internal Services (Horizon, Internet Services, Printing, Telephony).