Websites unavailable
Incident Report for Brother Rice High School
Resolved
The hosting provider was experiencing a complete outage on their platform which appears to have been resolved just prior to 11:00am. All hosted website are performing normally at this time.
Posted Sep 17, 2023 - 11:15 EDT
Investigating
We are experiencing trouble with our hosted websites this morning, including brrice.edu and help.brrice.edu. We are waiting for more information from our hosting provider and will post an update once more information is avaialble.
Posted Sep 17, 2023 - 07:15 EDT
This incident affected: Business Services (Website Hosting).