iPad App Downloads not working
Incident Report for Brother Rice High School
Resolved
This incident has been resolved.
Posted Sep 11, 2020 - 15:58 EDT
Monitoring
Apple has restored their service and we are seeing downloads from Self Service working again. We will continue monitoring this through the end of the day.
Posted Sep 11, 2020 - 13:51 EDT
Update
Students are unable to download the new apps added for Mentor Group competition due to the iTunes/App outage. We will post an update as soon as we have more information.
Posted Sep 11, 2020 - 13:25 EDT
Investigating
Apple is experiencing a major outage in their iTunes/App download system. This is impacting all iPad users and their ability to download apps from Self Service. We are waiting to hear from Apple an ETA for service restoration. We will post an update as soon as we have more information.
Posted Sep 11, 2020 - 12:45 EDT
This incident affected: Core Education Services (iPad Services).