PowerSchool Mobile app not syncing
Incident Report for Brother Rice High School
Resolved
This incident has been resolved.
Posted Feb 09, 2023 - 09:45 EST
Monitoring
The Mobile app service appears to be syncing/responding in a timely manner. We will continue to monitor this service for the remainder of the school day.
Posted Feb 06, 2023 - 13:24 EST
Investigating
We have observed that the PowerSchool Mobile app service is running degraded. Users are experiencing slow or no updates to their Mobile app and also the inability to login once logged out.

As a workaround, all student and parent users can visit https://brrice.powerschool.com to view information in their web browser.
Posted Feb 06, 2023 - 10:02 EST
This incident affected: Core Education Services (PowerSchool SIS).